Run ingest delays and slow queries

Incident Report for LangSmith

Resolved

Performance has returned to historic norms.
Posted Mar 25, 2025 - 16:04 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2025 - 15:42 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 25, 2025 - 15:30 UTC

Identified

We've identified an infrastructure issue causing run ingest delays and slow queries. Some queries are failing and retryable. We are actively working on a mitigation.
Posted Mar 25, 2025 - 15:30 UTC
This incident affected: LangSmith Frontend, LangSmith Playground, LangSmith API, and LangSmith Run Ingestion (US).