Intermittent timeouts when calling the LangSmith API
Incident Report for LangSmith
Resolved
This incident has been resolved.
Posted Oct 28, 2024 - 23:19 UTC
Monitoring
An infrastructure change caused a percentage of our backend calls to intermittently timeout.

This caused random timeouts in the LangSmith Frontend and caused LangSmith Run Ingestion to be delayed by anywhere from 1 to 5 minutes.

We have reverted the change and are monitoring for a recurrence.
Posted Oct 25, 2024 - 21:45 UTC
Investigating
We are currently investigating an issue that is causing approximately 5-10% of all incoming API calls to fail with a 502 error after a 60s timeout.
Posted Oct 25, 2024 - 21:08 UTC
This incident affected: LangSmith Frontend, LangSmith API, and LangSmith Run Ingestion (US).