EU: Slow or hanging queries in LangSmith UI and API
Incident Report for LangSmith
Resolved
Between approximately 1320 and 1820 UTC, the EU instance of LangSmith experienced degraded performance for all API calls including run ingestion due to a scaling issue with our production database. We worked with our database provider to resolve the issue by allocating additional resources and performance has returned to historic norms.
Posted Jan 13, 2025 - 22:08 UTC
Monitoring
We have worked with our database provider to scale up our production database for traces. All run ingest and API operations have returned to normal and we are continuing to monitor.
Posted Jan 13, 2025 - 21:14 UTC
Identified
We have identified a scaling issue with our production database for traces and are working to correct the problem.
Posted Jan 13, 2025 - 16:34 UTC
Investigating
We have received reports of slow or hanging queries in the LangSmith Frontend and API in the EU instance of LangSmith and are actively investigating.
Posted Jan 13, 2025 - 15:25 UTC
This incident affected: LangSmith Frontend, LangSmith API, and LangSmith Run Ingestion (US).