Looking for the EU status page? Find it here: https://eu.status.smith.langchain.com
Resolved
This incident has been resolved. Annotation queues are once again fully accessible in the US LangSmith UI. Please let us know at support@langchain.dev if you're still experiencing issues.
Identified
The cause of the issue has been identified and the team is currently working on a fix.
Investigating
We're investigating an issue where the annotation queue page may load very slowly or even freeze the UI after clicking the View Run button.